Notices
Results 1 to 21 of 21

Thread: Thread viewed issue

  1. #1 Thread viewed issue 
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    I have noticed that my normal way of viewing threads keeps resulting in viewed threads not getting marked as such. I tend to use the link bar at the top of a page to navigates between the forums and subforums.

    *Forum * Forum:Forum *Subforum *random thread a

    However I often jump from a thread to the main Forum, using the "Forum" link, but the system does not seem to recognize the tread that I have just left, "random thread a", as read. If I click any link other then the subforum link such as the "Forum:Forum" link or any other link (eg messages) I have to then go back at some point and click the thread again for the read attribute to be added.

    Is this something that can be adjusted so leaving the thread by any means will mark it as read?


    Reply With Quote  
     

  2.  
     

  3. #2  
    Administrator KALSTER's Avatar
    Join Date
    Sep 2007
    Location
    South Africa
    Posts
    8,232
    I see that when accessing the site from my cell phone, my viewed threads don't get preserved when logging on with my computer. I mightbe wrong, but the same might be happening when switching between computers as well.


    Disclaimer: I do not declare myself to be an expert on ANY subject. If I state something as fact that is obviously wrong, please don't hesitate to correct me. I welcome such corrections in an attempt to be as truthful and accurate as possible.

    "Gullibility kills" - Carl Sagan
    "All people know the same truth. Our lives consist of how we chose to distort it." - Harry Block
    "It is the mark of an educated mind to be able to entertain a thought without accepting it." - Aristotle
    Reply With Quote  
     

  4. #3  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    Quote Originally Posted by KALSTER View Post
    I see that when accessing the site from my cell phone, my viewed threads don't get preserved when logging on with my computer. I mightbe wrong, but the same might be happening when switching between computers as well.
    The system is currently cookie based which is probably why you see some inconsistencies. We can investigate other options.
    Reply With Quote  
     

  5. #4  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    is there a way for the cookie to be updated when one leaves the thread by any route?
    Reply With Quote  
     

  6. #5  
    Forum Freshman Bunsen's Avatar
    Join Date
    Jul 2011
    Posts
    14
    Quote Originally Posted by Paleoichneum View Post
    is there a way for the cookie to be updated when one leaves the thread by any route?
    Cookies are stored client-side. Perhaps you could find a way to synchronize your cookies between computers and mobile devices.
    Reply With Quote  
     

  7. #6  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    I realized I haven't clarified very well, my apologies.

    The problem isn't with the thread itself. It the forum read icons on each subforum which are not showing the change. the tread itself shows as read, but the forum doen't until you reenter it
    Last edited by Paleoichneum; July 25th, 2011 at 04:46 PM.
    If more of us valued food and cheer and song above hoarded gold, it would be a merrier world. -Thorin Oakenshield

    The needs of the many outweigh the need of the few - Spock of Vulcan & Sentinel Prime of Cybertron ---proof that "the needs" are in the eye of the beholder.
    Reply With Quote  
     

  8. #7  
    Moderator Moderator
    Join Date
    Apr 2007
    Location
    Washington State
    Posts
    8,324
    Quote Originally Posted by Paleoichneum View Post
    I realized I haven't clarified very well, my apologies.

    The problem isn't with the thread itself. It the forum read icons on each subforum which are not showing the change. the tread itself shows as read, but the forum doen't until you reenter it
    Same here.
    Meteorologist/Naturalist & Retired Soldier
    “The Holy Land is everywhere” Black Elk
    Reply With Quote  
     

  9. #8  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    This may be occurring because there is an unread post or thread in that sub-forum. You can try double-clicking the icon next to the forum( forum_new-48.png) to reset it. Alternatively, you can click the "Mark Forums Read" option at the bottom of the forum, as the migration to the new software may have caused a few inconsistencies.
    Reply With Quote  
     

  10. #9  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    Quote Originally Posted by Beaker View Post
    This may be occurring because there is an unread post or thread in that sub-forum. You can try double-clicking the icon next to the forum( forum_new-48.png) to reset it. Alternatively, you can click the "Mark Forums Read" option at the bottom of the forum, as the migration to the new software may have caused a few inconsistencies.
    My experimentation has shown its not due to unread threads being present in a subforum. The clicking will work for now, but it would be nice for the subforum to automatically update when the threads are read.
    If more of us valued food and cheer and song above hoarded gold, it would be a merrier world. -Thorin Oakenshield

    The needs of the many outweigh the need of the few - Spock of Vulcan & Sentinel Prime of Cybertron ---proof that "the needs" are in the eye of the beholder.
    Reply With Quote  
     

  11. #10  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    Quote Originally Posted by Paleoichneum View Post
    My experimentation has shown its not due to unread threads being present in a subforum. The clicking will work for now, but it would be nice for the subforum to automatically update when the threads are read.
    I'll continue to research this but it doesn't seem to happen for me. The only other thing I can think of would be if someone voted in a poll and did not comment in the thread, causing it to be flagged as unread. Does it happen all the time or only in certain forums?
    Reply With Quote  
     

  12. #11  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    Quote Originally Posted by Beaker View Post
    Quote Originally Posted by Paleoichneum View Post
    My experimentation has shown its not due to unread threads being present in a subforum. The clicking will work for now, but it would be nice for the subforum to automatically update when the threads are read.
    I'll continue to research this but it doesn't seem to happen for me. The only other thing I can think of would be if someone voted in a poll and did not comment in the thread, causing it to be flagged as unread. Does it happen all the time or only in certain forums?
    All the time. its any thime I leave a thread for any location other then the immediate subforum that the thread is in.
    If more of us valued food and cheer and song above hoarded gold, it would be a merrier world. -Thorin Oakenshield

    The needs of the many outweigh the need of the few - Spock of Vulcan & Sentinel Prime of Cybertron ---proof that "the needs" are in the eye of the beholder.
    Reply With Quote  
     

  13. #12  
    Comet Dust Collector Moderator
    Join Date
    Mar 2011
    Location
    New Jersey, USA
    Posts
    2,848
    It happens to me as well. Even after all threads have been read, the arrow icon on the forum list page still shows unread threads/posts. I either have to go back in to the forum and come out, or manually clear the double arrows. A waste of time and effort, which is one reason why my participation here has decreased by 75%

    There is another reason as well, that I will address in the proper discussion.
    Last edited by MeteorWayne; July 28th, 2011 at 07:21 AM. Reason: clarification
    Reply With Quote  
     

  14. #13  
    Moderator Moderator
    Join Date
    Apr 2007
    Location
    Washington State
    Posts
    8,324
    Does it happen all the time or only in certain forums?
    Every forum all the time.

    Possibly there is some confusion as well. I think we expect the letters to not bold once everything is read, similar to how threads work inside the sub forums. Never noticed the little boxes to the left until you mentioned it, which only seem to update if they are manually cleared.
    Meteorologist/Naturalist & Retired Soldier
    “The Holy Land is everywhere” Black Elk
    Reply With Quote  
     

  15. #14  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    Thanks for the info. I will see what I can find about this. Have you tried marking all forums as read to see if the issue persists?
    Reply With Quote  
     

  16. #15  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,627
    yes , and it does for me
    If more of us valued food and cheer and song above hoarded gold, it would be a merrier world. -Thorin Oakenshield

    The needs of the many outweigh the need of the few - Spock of Vulcan & Sentinel Prime of Cybertron ---proof that "the needs" are in the eye of the beholder.
    Reply With Quote  
     

  17. #16  
    Moderator Moderator
    Join Date
    Apr 2007
    Location
    Washington State
    Posts
    8,324
    Quote Originally Posted by Beaker View Post
    Thanks for the info. I will see what I can find about this. Have you tried marking all forums as read to see if the issue persists?
    It unchecks all the boxes, so that appears to be working. All subforums remain bold though.
    Meteorologist/Naturalist & Retired Soldier
    “The Holy Land is everywhere” Black Elk
    Reply With Quote  
     

  18. #17  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    I believe I have finally corrected the issue. You may need to mark all forums read one last time but it should work as expected now. Thanks for your patience!
    Reply With Quote  
     

  19. #18  
    Moderator Moderator
    Join Date
    Apr 2007
    Location
    Washington State
    Posts
    8,324
    It's doing the same things. Nothing is unbolded and all the boxes have icons once again. There's no way to look at the forum and know which subforums have unread post. argg.
    Meteorologist/Naturalist & Retired Soldier
    “The Holy Land is everywhere” Black Elk
    Reply With Quote  
     

  20. #19  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    Please delete the cookies in your browser and mark all threads as read. The thread marking is now done in the database so there should be no issues going forward.
    Reply With Quote  
     

  21. #20  
    Moderator Moderator
    Join Date
    Apr 2007
    Location
    Washington State
    Posts
    8,324
    Did that. The boxes are working now.

    Are all the sub-forum titles supposed to stay bold? If so I guess we'll get used to it; It would be better though, for consistency, if they resorted back to normal text after the subforum was read much like treads do within their subforums.
    Meteorologist/Naturalist & Retired Soldier
    “The Holy Land is everywhere” Black Elk
    Reply With Quote  
     

  22. #21  
    Forum Freshman Beaker's Avatar
    Join Date
    Oct 2004
    Posts
    63
    Quote Originally Posted by Lynx_Fox View Post
    Did that. The boxes are working now.

    Are all the sub-forum titles supposed to stay bold? If so I guess we'll get used to it; It would be better though, for consistency, if they resorted back to normal text after the subforum was read much like treads do within their subforums.
    Glad to hear! Yes, the forum titles stay bold and he descriptions are in standard font. The icon next to the forum title indicates the status.
    Reply With Quote  
     

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •