Notices
Results 1 to 38 of 38

Thread: anyone else having problems?

  1. #1 anyone else having problems? 
    Moderator Moderator AlexP's Avatar
    Join Date
    Jul 2006
    Location
    NY
    Posts
    1,838
    The forum's been really slow for me lately. Is anyone else experiencing this or is it just my computer? I click 'submit' for a post and it takes forever, then gives an 'error' page, but the post still goes through.


    "There is a kind of lazy pleasure in useless and out-of-the-way erudition." -Jorge Luis Borges
    Reply With Quote  
     

  2.  
     

  3. #2  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,624
    Ive been getting connection errors occasionally.


    Reply With Quote  
     

  4. #3  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Hmmm, I'll take a look at this issue. It's running well at the moment.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  5. #4  
    Forum Freshman
    Join Date
    Dec 2008
    Location
    In Your Face
    Posts
    43
    ive gotten connection errors and posts/loading times are ridiculous....
    Reply With Quote  
     

  6. #5  
    Time Lord
    Join Date
    Apr 2008
    Posts
    5,338
    Likewise, occasionally. Just this server.
    A pong by any other name is still a pong. -williampinn
    Reply With Quote  
     

  7. #6  
    Forum Ph.D. Nevyn's Avatar
    Join Date
    Jan 2007
    Location
    UK
    Posts
    881
    I only have problems with internet explorer, firefox works fine for me though.
    Come see some of my art work at http://nevyn-pendragon.deviantart.com/
    Reply With Quote  
     

  8. #7  
    Time Lord
    Join Date
    Apr 2008
    Posts
    5,338
    I had a few timeouts with firefox.
    A pong by any other name is still a pong. -williampinn
    Reply With Quote  
     

  9. #8  
    Universal Mind John Galt's Avatar
    Join Date
    Jul 2005
    Posts
    14,169
    Any occasional problems I have had also effected other sites, so I have taken them to be a difficulty at my end.
    Reply With Quote  
     

  10. #9  
    Moderator Moderator Dishmaster's Avatar
    Join Date
    Apr 2008
    Location
    Heidelberg, Germany
    Posts
    1,624
    I'm also having problems from time to time. This includes access times and sometimes timeouts for minutes after trying to submit a post.
    Reply With Quote  
     

  11. #10  
    Administrator KALSTER's Avatar
    Join Date
    Sep 2007
    Location
    South Africa
    Posts
    8,232
    Quote Originally Posted by Dishmaster
    I'm also having problems from time to time. This includes access times and sometimes timeouts for minutes after trying to submit a post.
    Same here.
    Disclaimer: I do not declare myself to be an expert on ANY subject. If I state something as fact that is obviously wrong, please don't hesitate to correct me. I welcome such corrections in an attempt to be as truthful and accurate as possible.

    "Gullibility kills" - Carl Sagan
    "All people know the same truth. Our lives consist of how we chose to distort it." - Harry Block
    "It is the mark of an educated mind to be able to entertain a thought without accepting it." - Aristotle
    Reply With Quote  
     

  12. #11  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Made some changes, let me know if it gets any better.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  13. #12  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Ok, last changes made it worse. Made some more changes. Will keep trying.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  14. #13  
    Administrator KALSTER's Avatar
    Join Date
    Sep 2007
    Location
    South Africa
    Posts
    8,232
    Early days still, but looks much better! :wink:
    Disclaimer: I do not declare myself to be an expert on ANY subject. If I state something as fact that is obviously wrong, please don't hesitate to correct me. I welcome such corrections in an attempt to be as truthful and accurate as possible.

    "Gullibility kills" - Carl Sagan
    "All people know the same truth. Our lives consist of how we chose to distort it." - Harry Block
    "It is the mark of an educated mind to be able to entertain a thought without accepting it." - Aristotle
    Reply With Quote  
     

  15. #14  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Looks like once in a while it's just having problems. MySQL (database) is spiking to 99% CPU usage once in a while. This is also when everyone is having problems (I assume). I'll see if I can adjust things a bit more.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  16. #15  
    Administrator KALSTER's Avatar
    Join Date
    Sep 2007
    Location
    South Africa
    Posts
    8,232
    I see there is a new version 5.1 of MySQL out.
    Disclaimer: I do not declare myself to be an expert on ANY subject. If I state something as fact that is obviously wrong, please don't hesitate to correct me. I welcome such corrections in an attempt to be as truthful and accurate as possible.

    "Gullibility kills" - Carl Sagan
    "All people know the same truth. Our lives consist of how we chose to distort it." - Harry Block
    "It is the mark of an educated mind to be able to entertain a thought without accepting it." - Aristotle
    Reply With Quote  
     

  17. #16  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    I've had to increase the number of connections that the database will handle at one time in order to solve some problems. I hope it works.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  18. #17  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,624
    Any luck finding the problems with the tread indicators?
    Reply With Quote  
     

  19. #18  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Quote Originally Posted by Paleoichneum
    Any luck finding the problems with the tread indicators?
    Sorry I didn't read that thread, posted feedback and will follow up.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  20. #19  
    Moderator Moderator Dishmaster's Avatar
    Join Date
    Apr 2008
    Location
    Heidelberg, Germany
    Posts
    1,624
    I am having problems accessing some threads like this:
    http://www.thescienceforum.com/The-C...Now-16459t.php
    Others work fine. Strange.
    Reply With Quote  
     

  21. #20  
    WYSIWYG Moderator marnixR's Avatar
    Join Date
    Apr 2007
    Location
    Cardiff, Wales
    Posts
    5,760
    for whatever reason (large image ?) that thread loads very slowly
    it does load however
    "Reality is that which, when you stop believing in it, doesn't go away." (Philip K. Dick)
    Reply With Quote  
     

  22. #21  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Quote Originally Posted by marnixR
    for whatever reason (large image ?) that thread loads very slowly
    it does load however
    For whatever reason the code that tried to figure out the size of an external image and re-size it becomes slow when the remote server is also slow. I'll have to put some kind of a watchdog timeout on this function.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  23. #22  
    (Q)
    (Q) is offline
    Forum Isotope (Q)'s Avatar
    Join Date
    May 2005
    Posts
    2,659
    I often get an error message: "Waiting for thescienceforum.com..."

    Sometimes it's a short wait and sometimes it's a long wait. Is this related to the above problems? I rarely, if ever, get that message on most other forums.
    Religious Fundamentalist Club - Member #1.
    Reply With Quote  
     

  24. #23  
    Time Lord
    Join Date
    Apr 2008
    Posts
    5,338
    Ditto. The problem began this month.
    A pong by any other name is still a pong. -williampinn
    Reply With Quote  
     

  25. #24  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Ok, I see the site was down again when I got home from work. Did some full complete table checks to see if anything was wrong with the database. I'm still not 100% sure what's going on other then MySQL is being a pain. It's one of the newer versions 5.xx.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  26. #25  
    Forum Masters Degree samcdkey's Avatar
    Join Date
    Jun 2006
    Posts
    640
    I keep getting this message

    phpBB : Critical Error

    Could not connect to the database
    Homeland Security Advisory System: RED
    Reply With Quote  
     

  27. #26  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Quote Originally Posted by samcdkey
    I keep getting this message

    phpBB : Critical Error

    Could not connect to the database
    Ya, I have to figure out what is going on with MySQL. I've used it for years with much more intense stuff and never had these problems. I may need to uninstall the packaged version and just custom compile a new one.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  28. #27  
    (Q)
    (Q) is offline
    Forum Isotope (Q)'s Avatar
    Join Date
    May 2005
    Posts
    2,659
    I'm not sure if this info helps at all, but I got this "General Error Message" after a lengthy wait:

    Could not obtain post/user information.

    DEBUG MODE

    SQL Error : 2013 Lost connection to MySQL server during query

    SELECT u.username, u.user_id, u.user_level, u.user_posts, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile, p.*, pt.post_text, pt.post_subject, pt.bbcode_uid FROM phpbb_posts p, phpbb_users u, phpbb_posts_text pt WHERE p.topic_id = 16472 AND pt.post_id = p.post_id AND u.user_id = p.poster_id ORDER BY p.post_time ASC LIMIT 15, 15

    Line : 406
    File : viewtopic.php
    Religious Fundamentalist Club - Member #1.
    Reply With Quote  
     

  29. #28  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Well I discovered a few things.

    First our anti spam queries that run in the background to kill off spam were causing the database tables to lock up for a long period of time. This in turn would cause apache threads to stick and take a very long time to respond or close. The domino effect would happen each hour on the hour when the spam clearing would run. It would sometimes result in threads not finishing before the next run, eventually the entire site would come to a standstill. Now that I've identified the problem we should have far less issue.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  30. #29  
    Time Lord
    Join Date
    Apr 2008
    Posts
    5,338
    And more spam? :|

    Couldn't you block spam accounts with a stronger capcha? Redirect applicants through an easy little science quiz.
    A pong by any other name is still a pong. -williampinn
    Reply With Quote  
     

  31. #30  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Quote Originally Posted by Pong
    And more spam? :|

    Couldn't you block spam accounts with a stronger capcha? Redirect applicants through an easy little science quiz.
    The capcha is not the problem at the moment. The bots are not getting past it. It's real people that spam us. I do kind of like that quiz idea
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  32. #31  
    (Q)
    (Q) is offline
    Forum Isotope (Q)'s Avatar
    Join Date
    May 2005
    Posts
    2,659
    Quote Originally Posted by (In)Sanity
    Well I discovered a few things.

    First our anti spam queries that run in the background to kill off spam were causing the database tables to lock up for a long period of time. This in turn would cause apache threads to stick and take a very long time to respond or close. The domino effect would happen each hour on the hour when the spam clearing would run. It would sometimes result in threads not finishing before the next run, eventually the entire site would come to a standstill. Now that I've identified the problem we should have far less issue.
    Much better now, so far so good. Kudos.
    Religious Fundamentalist Club - Member #1.
    Reply With Quote  
     

  33. #32  
    Time Lord
    Join Date
    Apr 2008
    Posts
    5,338
    Quote Originally Posted by (In)Sanity
    Quote Originally Posted by Pong
    And more spam? :|

    Couldn't you block spam accounts with a stronger capcha? Redirect applicants through an easy little science quiz.
    The capcha is not the problem at the moment. The bots are not getting past it. It's real people that spam us. I do kind of like that quiz idea
    A capcha can filter more than machines from people. It can filter people by attitude or knowledge. For example people who can't even fake respect for science. Or the capcha could present posting guidelines followed by a comprehension test. Spammers won't bother.

    That's a lot of work to set up but maybe better in the long haul.

    ***

    No lag now BTW.
    A pong by any other name is still a pong. -williampinn
    Reply With Quote  
     

  34. #33  
    Forum Radioactive Isotope Paleoichneum's Avatar
    Join Date
    Oct 2008
    Location
    Washington State, USA
    Posts
    4,624
    Still not luck with the thread indicators?

    Hmmm....it seems to have been fixed, I'm not having any problems now. :?
    Reply With Quote  
     

  35. #34  
    (Q)
    (Q) is offline
    Forum Isotope (Q)'s Avatar
    Join Date
    May 2005
    Posts
    2,659
    Over the past couple days, I've noticed the same long delays as before when hitting the submit button with the message...

    Waiting for www.thescienceforum...
    Religious Fundamentalist Club - Member #1.
    Reply With Quote  
     

  36. #35  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Quote Originally Posted by (Q)
    Over the past couple days, I've noticed the same long delays as before when hitting the submit button with the message...

    Waiting for www.thescienceforum...
    Yes, I've noticed this as well. I think a reboot might be in order.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  37. #36  
    Forum Isotope (In)Sanity's Avatar
    Join Date
    Oct 2004
    Location
    Mesa AZ
    Posts
    2,697
    Ok, server was just rebooted about 3 minutes ago. Hope it helps.
    Pleased to meet you. Hope you guess my name
    Reply With Quote  
     

  38. #37  
    (Q)
    (Q) is offline
    Forum Isotope (Q)'s Avatar
    Join Date
    May 2005
    Posts
    2,659
    Seems better. Thanks.
    Religious Fundamentalist Club - Member #1.
    Reply With Quote  
     

  39. #38 Re: anyone else having problems? 
    Forum Bachelors Degree
    Join Date
    Mar 2009
    Location
    Plutonia
    Posts
    400
    Quote Originally Posted by Chemboy
    The forum's been really slow for me lately. Is anyone else experiencing this or is it just my computer? I click 'submit' for a post and it takes forever, then gives an 'error' page, but the post still goes through.
    Yes... (followed by some laughter under his breath) - because i have a dial up connection, so i don't know what kind of connection you are working with? The same? Broadband is very fast... i need to get it!!!!!!
    Only the mind can think twice simultaneously about a subject, but only one thing can inexorably come out of it. A choice.
    Reply With Quote  
     

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •